multiple mice unable to click

Feb 4, 2010 at 5:01 AM

I have a problem with the multiple mice input.

I followed the video and installed the driver successfully and was able to start up multitouch.driver.console and multitouch.service.console without any problems

I get two red dots on my screen and when I go to multitouch.configuration.wpf.exe I disable the input from the native mouse but when I did that the red dots aren't able to click anything.

It's really frustrating now because since I'm not able to click anything after I start up multitouch.service.console I can't change the input in the configurations.

I'm running Windows 7 Ultimate x64

Feb 4, 2010 at 6:13 PM

Have you started Multitouch.Service.Console first, before Multitouch.Driver.Console?

Feb 10, 2010 at 6:03 AM
Edited Feb 10, 2010 at 6:05 AM



I got the same problem with my Windows 7 Ultimate x64. Im unable to click with the mouses. And is it normal that the default windows cursor is also visible after blocking the input, but of course it doesnt move?


I did everything just like in the video and i have also tried to restart my PC after that.


I have checked the both threads with this same problem and checked what other people did wrong.


In the video there is  a big mouse picture at your desktop? And its at paint too. What is it and shouldnt it be visible?

Feb 13, 2010 at 12:11 AM
Edited Feb 13, 2010 at 12:16 AM

Hi Guys

I am having the same problem as above and now im stuck. I am running win 7 x64, have tried installing (as per instructions) the services and when i start them, they immidiately stop working. I also tried the "video" method, also getting the two red dots that move independantly but the "clicks" dont work and as soon as i have disabled the native input, i have to use my keyboard to re-enable it because the "Mice" stop working. After hunting around, i found that there is an issue with one of the devices in the device manager, namley the "Universal Software HID Device", When i go into its properties, i get the following reported error: "Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)" Could this be the problem and are you all having the same problem.

The other thing i noticed was that there was no "Pen and Touch" in the control panel, I installed a windows one (+-300mb) that i downloaded from the net, and now in my system infomation im getting a pen an touch field that reports that there are no pen or touch devices found for this display. How do i fix this? One suggestions on one of the fourms was to regedit the machine and change the values in the "Tablet PC" directory to 1 (i.e. Make windows think its a tablet computer) but i was unable to change this. Please can anyone suggest how i should proceed from here...

Very keen to get this working!!! looks amazing... love chasing the dots around :) but thats all ive been able to do for now. If you would like any more infomation or detail to help fix this, please lemme know :)

Thanks for any further development


Edit: the reported error is actually the Device Status, and its dialog reads: "Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)" Thanks :)

Feb 13, 2010 at 10:32 AM

Download and replace the file from download page. And then reinstall the driver. Or follow this to disable driver signing:

Also make sure you start Multitouch.Service.Console.exe before Multitouch.Driver.Console.exe. If you are using windows services then you should install ONLY one of them Multitouch.Driver.Service.exe OR Multitouch.Service.exe (NOT BOTH).

Feb 15, 2010 at 9:22 PM

Hi nesher

Thanks! that solved the driver problem :) but it seems that i am still unable to use the dots to click anything. I have tried the instructions and am getting nothing :( im running dual monitors (1680x1050 each) on a single nvida gts 250. and im using win 7 ultimate x64. I can move the dots independantly but i cant seem to get them to click... even after i trying all the methods listed.

I tried the services and the consoles (seperatly) and have yet to succeed...

Any help would be appreciated :)

Feb 16, 2010 at 9:46 PM

Hi nesher, i managed to get it to work. seems like the logitech setpoint interface was messing with the system :| But its now working :) i now have the issue with dual monitors but ill go over the the other dicussion for that :) thanks for all the help guys

Mar 3, 2010 at 10:00 AM


I have the same problem (win7 ultimate 64). I only see the red dots when using multiple mice but no click function.

I reinstalled the driver with the new file you mentioned above and I disabled driver signing.

Multiple Mice still does not work but TUIO does work after enabling TUIO Input and then restarting MultitouchServiceconsole and DriverConsole.

The driver seems to be a bit unstable on 64bit? It worked better on a 32bit system.





Mar 3, 2010 at 10:12 PM

Sorry it took so long to respond.

I got the multiple mice working after I followed the advice that nesher gave me in his first reply post.

The way I solved it was by loading up a command prompt (start menu->search cmd)

I then did cd {multitouchvistafolder}

and then I typed "Multitouch.Driver.Console.exe" but I didn't click enter to run it

I then went back to the multitouchvista folder and ran Multitouch.Service.Console

After it ran, I wasn't able to click anything so I pressed Cntrl+Alt+Delete to bring up my taskmanager and then used my arrow keys to scroll to the command prompt I started up before.

I scrolled to the item in the task manager and pressed enter to switch to it.

I pressed Enter to start up Multitouch.Driver.Console and then the transparent mouse came up and I was able to use multiple mice.

Hopefully this will clear up things.

Thanks nesher!

Sep 17, 2010 at 8:28 PM

I've been struggling with the same issue for 2 weeks.  I followed blablasometin8 suggestions and it finally worked?  Thanks for the info!

Nov 7, 2010 at 8:58 PM
Edited Nov 9, 2010 at 9:09 PM

I've just registered to confirm I've followed these instructions and I've got it to work. Thanks for the help guys. 

I'm running on Windows 7 64-bit. 

To confirm, I downloaded the "" file and replaced the original in the driver folder of the Multitouch folder. Then I installed the driver (after uninstalling the last one). Now each time I use the program, I load up a command prompt, and type in "Multitouch.Driver.Console" at the location of the Multitouch folder, but I don't press enter to start it. 

Instead, I go back to the Multitouch folder and run the "Multitouch.Service.Console" application. The mouse will stop working for a couple of seconds, then I press alt-tab to go to the command window I opened earlier (since clicking on stuff stops working), and I press Enter to run the Multitouch.Driver.Console application. Then it will start working. 

1)  Download and replace the original version of this file (in my case it was located at "MultiTouchVista_-_second release.../Driver/x64/". 

2) Load up a command window. 
3) Run the Multitouch.Service.Console program 
4) Use the keyboard to the command window and to run the Multitouch.Driver.Console application.

UPDATE : I tried this the following day and this no longer works. It turns out the Multitouch.Configuration.WPF application doesn't seem to save configuration settings. I went back into the settings for this and checked that checkbox again, and then ran the Service.Console and then Driver.Console and it worked again.

I assume the developers will eventually have a program with an installer and all that? Is it being worked on? I think this program could have great potential now that people are developing for windows phone 7. It might be worth charging a few pounds for the program. That could act as the incentive to make improvements to the installation and running of the program!  

Oct 16, 2011 at 11:17 PM
Edited Oct 16, 2011 at 11:33 PM

Hi folks,

I had everything running we'll last week. I'm developing a flash application to run on some nice big touchscreens at the Queensland University of Technology. 

When coming back to the project this morning , I get 2 red dots when running the Service. Console and Driver.Console, but no touch events. 

Unlike ciaran036 above re-running Configuration.WPF does seem to save its settings, and while the service console is running I can load it up and enable and disable the movement of the mouse. 

The one thing that seems diffrent today is that opening the Configuration.WPF.exe is very slow. (30-45 Seconds). Last week this was very snappy. Even clicking on the "configure device" button results in a 15-30 second delay before the small window with the check box appears.

This morning I've tried a number of things to correct the problem. I downloaded again and then "removed" the old driver using devcon and then Installed again. I've confirmed my windows System reports Touch input is available with 255 Touch Points. 

I'm running Windows 7 Home Premium 64 bit. 

Any help would be much appreciated.



In an attempt to remove the default windows ripple I renamed the WISTIS.exe. (As per some advice for Wacom Table Users). I guess I must not have rebooted last week.

After restoring this file everything works again.

Oct 19, 2011 at 11:46 AM

same problem.none of these fixes 7 logitech setpoint.updated cat file.when i disable the native mouse support i can no longer click on anything.The red dots do move

Apr 20, 2012 at 1:36 PM

I had similar behavior to what the OP describes -- though I would occasionally get a click somewhere, just not at a dot -- except I'm on 32-bit 7.

FIX: The culprit ended up being the fact that I had dual monitors (laptop + external). When I closed the laptop lid and used only the external monitor it started working.

(I had to do a few things before it ended up running fine: close the lid, start the service.console and driver.console, open the wp.exe and disable native mouse input, close wp, driver.console, and service.console, then relaunch service.console and driver.console. After that it worked -- wp had saved the setting. It still doesn't work with Flash though which is why I wanted MTV in the first place :( )

Mar 9, 2013 at 4:12 PM
I think there is a good reason why this project and others like it never really took off.....