Touch Pointer not visible

Nov 26, 2009 at 2:46 PM


First off all I'd like to express my thanks to everyone involved in this project! Great work and keep it up!
However, I got one thing not working and I am afraid it's got to do with Windows 7. But, maybe you guys have a solution because Google didn't, nor a search in the existing discussion topics.

I downloaded the latest package (refresh 2). Followed the instructions in the movie and got almost everything working!

  • The HID driver (x64) is installed (and disabled, than enabled) and according to Windows running ok. 
  • The multitouch.driver.console started and running
  • The multitouch.service.console started and running
    • Configured for MulipleMice in the Multitouch.Configuration.WPF
    • Red dots are individually moving according to the input devices (mouse and trackpad) and the standard mouse pointer following accordingly.
  • Pen and touch configuration is set as shown in the movie, including "show the touch pointer when..." (I double checked that one).
  • But when I configure the MultipleMice option for blocking the native windows mouse input (so I can use the Windows 7 multi touch), the touch pointer never appears. The red dots still move according to their input on the mouse and trackpad. But are otherwise unresponsive (I can't click anything). The native mouse pointer is still visible but doesn't respond to anything.

I've rebooted, rechecked, redone everything more than once, but i just can't get the touch pointer to appear. 
I'm working on a Windows 7 RC (build 7100) 64 bit, fairly regular notebook, using the (synaptics) touchpad and a mouse.

Does anyone have a solution for this?



Nov 26, 2009 at 5:56 PM

You have to first start multitouch.service.console and then multitouch.driver.console.

Nov 27, 2009 at 7:01 AM

Thank you Nesher,

So simple, and yet I failed to do just that! Anyway, it works great now.

Thanks again!

Dec 4, 2009 at 12:38 AM

Hi, in my case is opposite

Please help, I installed win 7 driver *32 and follow this video instruction.
First time install, everything work and OK, see the red pot and mouse ion, and click events ..

after I power off, and re-run the services, it doesn’t work
The service that I run:


just only show the red dot but the mouse cursor disappear, red dot only respond move,

and couldn't run multitouch.driver.console.exe, the mouse cursor not there

 but the pen and touch property shows available
and within multitouch.service.console window shows:
input provider in settings - multipleMice found: .. version:
started input provider
multi-touch input service is running
press Enter to stop and exit

Do I miss any steps?

sorry I double post, I am afraid you miss there, I am too eager want to fix this problem


Thanks in advance

Dec 4, 2009 at 9:20 AM

Hello Uncledj,

It might be the case that the de input is configured for MulipleMice in the Multitouch.Configuration.WPF and the native mouse blocking option is enabled. In that case the native mousepointer will freeze and the "red dots" will move. 
You must run the  multitouch.driver.console.exe in order to get things to work so:

  • start the multitouch.service.console as you  usually do
  • now you lose mouse control but navigate to the folder using the keybord (Alt+Tab and the arrowkeys).
  • navigate (using the keyboard) to the multitouch.driver.console.exe and press enter (to run it).
  • navigate (using the keyboard) to Multitouch.Configuration.WPF.exe file and press enter (to run it). 
  • now the configuration window should appear (might take some time).
  • navigate (using the keyboard) to that window and select "Configure device" using the "Tab"key to navigate to it, and the spacebar to select it. 
  • a new small window should open, navigate to there (Alt+Tab) if necessary, and select the option using "Tab, press spacebar to disable the option. 
  • use "Tab" to navigate to the "OK" button and press "Enter"

The default mouse should be controllable, as well as the red dot, if this was the problem. 

I hope my answer is of any use and good luck.



Dec 4, 2009 at 5:49 PM

Thanks RobertFrensen

it works