More win7 trouble

Aug 18, 2009 at 2:46 PM

Hi, I tried to get MT Vista running with my MT setup. I'm producing TUIO and would like MTVista to translate it to windows events for me


I followed when I installed


1. I ran "Install driver.cmd"

2. I opened Device manager

3. Disabled the hid

4. Enabled the hid

5. Did the pen and touch thing

6. I ran Multitouch.Service.Console.exe and everything seemed fine

7. I ran Multitouch.Driver.Console.exe and everything still seemed fine

8. I ran Multitouch.Configuration.WPF.exe and changed input device to TUIO

9. and nothing...



I'm running rc1 32-bit and I'm 100% sure my TUIO setup is working correctly.


What am I missing?

Aug 18, 2009 at 3:24 PM

i have a same problem, i have installed all drivers fine and run multitouch.driver as service, but there's not response on any touch and several TUIO simulators. I know that multitouch.driver is binding on 3333 udp port, so problem is not in TUIO

Aug 18, 2009 at 8:29 PM

multitouch.driver does not use udp and port 3333. there must be something else that uses this port.

Aug 18, 2009 at 9:11 PM

but when driver is running, i can't run any TUIO clients, for example Max/MSP client, it's can't bind to 3333 port, when i stop mt.driver service, Max/MSP patch starts work and no problem with udp

Aug 19, 2009 at 6:58 AM

Multitouch.Service is listening on port 3333 if TUIO input provider is active, not mt.driver.
What is Max/MSP?

Aug 19, 2009 at 7:28 AM
Edited Aug 19, 2009 at 7:33 AM

Here about it Max is a graphical development environment for music and multimedia. And here is some TUIO client for different languages. If you install mt.driver as Windows Service, mt.service starting automaticly when driver started. And listen 3333 port, but mt.service don't response on tuio messages

Aug 19, 2009 at 8:43 AM

"Multitouch.Service is listening on port 3333 if TUIO input provider is active, not mt.driver." It does indeed listen, but that's all it does. I don't get any kind of out put from the Multitouch.Service. As i stated in my original post I might have missed something, but it's not working at the moment...

Aug 19, 2009 at 6:08 PM

What are you using to send TUIO?

Aug 20, 2009 at 8:19 AM

It's custom built hardware. But I am producing TUIO output that is working with other TUIO application such as java client fount at, NUI snowflake ( and pyMT (


My TUIO packages looks something like this:

['/tuio/2Dcur', ',si', 'alive', 10002, 10007]
['/tuio/2Dcur', ',sifffff', 'set', 10002, 0.41805556416511536, 0.4977777898311615, 0.0, 0.0, 0.0]
['/tuio/2Dcur', ',sifffff', 'set', 10007, 0.72342948119831231, 0.9124718244651562, 0.0, 0.0, 0.0]
['/tuio/2Dcur', ',si', 'fseq', 679]

Aug 20, 2009 at 6:03 PM

I'm using TUIO client library from . It should work. Can you debug and what is wrong?

Aug 21, 2009 at 8:40 AM

Everything *should* work, but it doesn't

Did I setup up your program right?

Can I start it with some debug flags?


The TUIO I'm sending is working, I'm not saying that you're program can't read TUIO. I'm just wondering if I've set it up right and if there is a way for me to test it?

Aug 21, 2009 at 7:27 PM

Your install steps are correct. First I would test if the driver installed correctly. Change input provider to multiple mice. You will see red dots. If you can move them than multiple mice and service is working. Then start driver.console.exe additionaly to service.console.exe and test if events are received by driver/w7.

There is no debug flags. If you have Visual Studio you can try to debug the service. Set breakpoint in project Multitouch.Service.Logic, class InputProviderManager, method inputProvider_NewFrame.

Aug 24, 2009 at 8:21 AM

I changed the input provider back to multiple mice. I get one red dot that moves around about 2x the speed of my normal mouse, it doesn't seem like I can do anything with it thou (played around in paint and only got input from my normal mouse)

I started "Multitouch.Driver.Console.exe" but all it said (both when runing tuio and multimice) was:

Multitouch driver is running.
Press ENTER to stop and exit.

Aug 24, 2009 at 5:40 PM

If you use multiple mice provider you have to "block" your real mouse. Start Multitouch.Configuration.WPF.exe, press configuration and check the option "block mouse".

Aug 26, 2009 at 12:44 PM
Edited Aug 26, 2009 at 1:04 PM

I tried to use the multiple mice provider and blcoking the real mouse. I only get one red dot and I can't use that red dot in paint.


From the clips I've seen people get more then one dot so it seems that the problem is laying underneeth the tuio layer..



I added a print to TuioContact.cs and recompiled "TuioProvider.dll" and "TUIOProvider.pdb" and my tuio input is getting there alright so the problem seems to be later in the chain...

Aug 26, 2009 at 5:49 PM

how can you see red dot with TUIO? red dots are only available with multiple mice.

Aug 27, 2009 at 9:19 AM

I'm not getting any red dots with TUIO...


The red dot I was talking about was the _one_ I saw when running the multiple mice input.


I brought it up since it seems that there's nothing wrong with the input it seems my problem is laying between MTVista and win7, I can't get any events from either multiple mice input or tuio...

Aug 27, 2009 at 8:00 PM

If you go to System in control panel, can you see something like - "Pen and touch: Pen and Touch Input Available with 255 Touch Points"?


Aug 28, 2009 at 8:55 AM

Yes, it says exactly that..

Aug 28, 2009 at 5:46 PM

This is strange :( Are you sure you are using the latest version? There was an error in earlier builds.

Aug 30, 2009 at 4:32 AM

I have exactly the same problem. I'm not sure many people are using TUIO servers with this project. Nesher, I built the TUIO_CPP_1.4 server reference implementation (from and modified their SimpleSimulator project to send TUIO to my Win7 box running your refresh 2. It just doesn't work.

You can verify by building this (c++, it needs SDL, but it builds on OSX or Windows).

This project includes a client and server implementation; i modified the server impl. The client you use is built by the same people.

Your TUIO provider receives the packets, but it does nothing. I even brought up the calibration screen and setup screen on "touch/pen setup" win7 and tried to get somethign to register, but not a sausage.


Aug 30, 2009 at 6:04 PM

How do you generate TUIO? With simulator? Does it runs on the same PC as MTV?

Aug 30, 2009 at 7:18 PM

Yes, with the c++ simulator. Nope, not the same PC. No firewalls. I've verified that the MTV box is listening on I've watched the network connection receive packets.

Also, I tried to use OSCemote iphone app with MTV too, and in MultiTouch mode, it doesnt work. In button mode, MTV throws null reference exceptions on each packet received.


Aug 30, 2009 at 9:08 PM

OSCemote works fine to me in Multi-Touch mode, i can get up to 5 contacts in MTV (as the iPhone support only 5 fingers at time)- Don't try to use Buttons/Sliders/Accel or what else, those will not work.

Aug 31, 2009 at 6:07 PM

I have just tested OSCemote with MTV + hid driver - works perfect.

Sep 3, 2009 at 5:54 PM

Hello, it seems that I am experiencing the same kind of problem:

I am running windows seven (limited time full version) 32bit and I did the same install procedure for MTV.

TUIO input is provided by a TUIO simulator or wiimoteTUIO. It seems that TUIO is provided correctly.

I tried multimouse half-successfully: I can move the 2 red dots but they don't interact with win7.

My guess: MT service is OK but MT driver has something wrong in my win7...

How can you check that the driver is properly installed and the new HID is ok?


Note: with TUIO input it seems that it is working very briefly but with a lot of lag. I can see the win7 touch pointer appear randomly but I can't control it. Wierd, hu?



Sep 29, 2009 at 11:10 AM

if I buy the OScemote software, Do I need  to implement the InputProvider? 

and Anyone knows the format of these points which are sent from OSCemote, and Can I get these points information in PC easily?

Sep 29, 2009 at 12:26 PM

It works fine with the TUIO InputProvider. OSCemote has few panels, use the one called "Multi-Touch".

Sep 29, 2009 at 2:46 PM

oh, I see ...Many thanks :)


Jan 10, 2010 at 9:37 AM
beshanoe wrote:

i have a same problem, i have installed all drivers fine and run multitouch.driver as service, but there's not response on any touch and several TUIO simulators. I know that multitouch.driver is binding on 3333 udp port, so problem is not in TUIO

 I have the same problem. I use the ccv 1.3 for multitouch. i have chosen the "tuio udp" box. but nothing happen. everything goes right as i follow the step the accomplish the setup. what's wrong? is the version of windows happen? i use the ultimate windows7, and language is chinese

Mar 11, 2010 at 4:46 PM

I got the exact same problem.

It's not working with CCV 1.2 or CCV 1.3.


What is the problem?

Apr 6, 2010 at 11:06 PM

I have exactly the same problem.

I have downloaded all the source code and I have placed breakpoints on several places down the pipeline:

First, I set a breakpoint here (service application):

<font size="5">



void inputProvider_NewFrame(object sender, NewFrameEventArgs e)




and when I touch the TUIO Simulator VS breaks here.

Then I set the breakpoint here (driver application):

<font size="5">



private void SendReport(MultiTouchReport report)



var result = device.WriteReport(report);


and finally I set the breakpoint here (driver application, VB assembly):


<font size="5">



Public Function WriteReport(ByVal Report As HidReport) As Boolean

<font size="5">



  Return WriteReport(Report, 0)

End Function

and VS does break as well, I can even go down the pipeline and I reach the following code:

<font size="5">



Return NativeMethods.WriteFile(_HidWriteHandle, Buffer, Buffer.Length, BytesWritten, Nothing)

So I am sure that the message is running down the pipeline and supposedly it should reach the operating system, but in reality, Windows 7 never gets the WM_TOUCH message.

I have tried with several Windows 7 native apps like Paint, and I have tried with WPF4 apps as well, but nothing happens. Simply Windows 7 never gets anything from MTVista.

If I replace TUIO and use multi-mouse instead, I get the red dot and I also get events when I block, so the problem is definitely related with TUIO

Apr 7, 2010 at 4:42 PM

*** UPDATE ***

I was able to make the TUIO simulator work with MTVista's Windows 7 driver. On another thread @nesher let me know that mouse events have a higher priority over the touch events in the Windows 7 pipeline and therefore, trying to use the simulator on the same computer would not be possible as the mouse interaction with the simulator would override the touch events every time.

In order to solve this I installed the TUIO simulator on another computer and I used an UDP forwarder that I downloaded from here:

and I was able to control the computer remotely.

Now I will start trying it with the hardware setup.

I also verified @nesher's assessment concerning the priority of mouse effects: even when I am controlling the computer remotely with the simulator, if another user touches the mouse the touch events are interrupted, so yes, the mouse has a higher priority.

Hope this helps some people on this thread as well.

Dec 16, 2010 at 5:15 PM

Hey murven

I tried ur way, but it dosent work .

i use one computer running ccv and by changing the config file i can pop out the tuio message to another computer, verified by using nc listen to port 3333.

but mtvista is still no respond.

May 2, 2011 at 5:14 PM

I experience exactly the same problems as described by some previous posts.

Using ccv 1.4 as TUIO sender and windows 7-64 bit.

MTVista does not react to TUIO at all.

Read all the avove hints and tried many things including deactivation of windows firewall - no luck.

The TUIO messages are there and are correct - e.g. OpenMT works, but does not provide the functionality I need.

Any solution meanwhile?


Oct 12, 2011 at 3:33 AM

Hi, I can not install the driver Multitouch Vista. When I open it instantly closes. Can you help me?