First Example of Multitouch "Hello World" program example not working

Apr 12, 2009 at 11:37 AM
I downloaded the latest source code form the repository (change set 19041), successfully compiled everything but the sample app doesn't seem to want to work.
I'm using VS2008. could that be a bug somewhere?
Apr 13, 2009 at 9:41 AM
What exactly is not working?
Apr 13, 2009 at 7:51 PM
I can't drag the TextBlock around.

I changed the window class and all nd inserted this into the Grid area:
    <TextBlock Text="Text" etc...>

Any idea why it's not working?
Apr 14, 2009 at 2:31 AM
same in my cases, using VS2008, except work inside  VM, hope not make any difference with mouse event
the red dot not respond. any idea why?
Apr 14, 2009 at 8:30 AM
I'm still browsing through the MTV-Framework's source code, but I rather leave this with nesher as he knows best what might be causing this.
Apr 14, 2009 at 11:16 AM
If red dots are not responding then mouse was not correctly recognized. I have not tested multiple mice provider in VM.

@thomasthep: I have just checked your xaml. It seems this is a bug. I will fix it. For now you can use following xaml.

            <TextBlock Text="Text" Foreground="White" FontWeight="Bold" FontSize="24"/>

Apr 14, 2009 at 1:46 PM
Thanks, nesher

yes, VM mouses conflict, work fine in other machine, vista and windows 2003, vista consume more resource than windows 2003. under very similar config.
Apr 14, 2009 at 1:58 PM
I'm not using VM. Just plain old XP Pro SP3 with VS2008.
Could have figured that out myself.
Anyways, thanks for the update.
Apr 14, 2009 at 6:24 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Apr 14, 2009 at 7:13 PM
Edited Apr 14, 2009 at 7:14 PM
Bug in TouchablePanel is fixed now.
Apr 14, 2009 at 9:31 PM