[SOLVED] ONLY Y-position mouse movement on Surface 1 (Windows 7)

Mar 4, 2012 at 12:19 PM

Hello everyone,

I have installed Windows 7 on my Surface 1. I have installed Multitouch vista, and it gets the input from the Surface Input. (See Hebu's instructions in this topic: http://multitouchvista.codeplex.com/discussions/216086).

Now when I touch the Surface screen the mouse arrow positions itself at the left of the screen (near the Start orb), and when I move my finger it only follows the vertical (Y-position) of my finger and not the X position. So I can only move the mouse arrow up and down.

What could be the problem? (BTW, I think there shouldn't be a mouse arrow at all but right? It does not show the Windows touch point although they are enabled in the Pen and Touch settings.

Using the latest source 32bit.

Kind regards,


Mar 11, 2012 at 8:03 PM

Okay, so I reinstalled Windows 7 on my first generation Surface and copied the Surface Input calibration files; still the same problem. I then unplugged my second screen, and did another calibration with only the Surface screen. And now it works like a charm :)!

The mouse onscreen was showing because in "Pen & Touch" the "Always show a touch pointer" was checked, so I unchecked that.