multi-touch services on windows 7

Dec 15, 2010 at 8:36 AM

Hi all

Anyone who can help me on creating multi-touch services on windows 7?

Folloing is what I had tried...

I am using touchlib to create TUIO protocol, and run Multitouch.service.console.exe, Multitouch.Driver.console.exe step by step after windows started. It works well.

When I tried to make it as services on windows 7, I made Multitouch.service.exe and Multitouch.Driver.service.exe as service, and it installed successfully. Default as "mannual". When I started it manually, right click multitouch input, click start. It returned an error. what it say is like "the services stopped after it started, there is nothing to do....(I am using chinese language, so it might not translated correctly)". This service is still stopped.

The same problem as another driver service.


What I had tried in other way, is to change source code of Multitouch.Driver.console.exe and Multitouch.service.console.exe, make it sleep after the thread started. In this situation, everything seems to be good, 3 process started, and I can see it in task manager. And in the information, I can see the osc window, the points I touched showed correctly in osc.exe console. But windows does not answer me.... It seems that Multi-touch does not received TUIO information, or Multi-touch can not transfer the TUIO information to windows system.

Looking forward for your help, thanks in advance.


Dec 16, 2010 at 6:58 AM
Edited Dec 16, 2010 at 7:01 AM

Hi all

I tried again today, new win7 system is installed, and the Multitouch.Driver.Service.exe had been made as a service sucessfully. It also can be started.

But I still have a problem. It can be started manually, but when I made it start automaticly, the service can not be start automaticly on windows start up.

I found the error log in system information, it showed "Can't create duplicate token".


Another problem, though the service can be started manually, but it does not work at all. when the service started, I saw a red dot at mouse, but I am sure TUIO sender is OK. If I open Multitouch.service.console.exe and Multitouch.Driver.console.exe, everything works well. It seems that the service still using MultipleMice.

Is there anyone who can help me!

Best regards,