Upgrade from .Net framework 3.5 to 4.0?

Mar 18, 2010 at 8:50 PM


I have some questions regarding the framework and the controls. As far as I have understood, the mt: controls are created against .Net 3.5 and are customized to handle the WM_TOUCH messages, correct? Also I understand it is now possible with .Net 4.0 RC to create multitouch apps where the wpf controls can handle multitouch natively (that is without having to write any WM_TOUCH message interpreters. So I have tried to create a multitouch app in .Net 4.0. What I see there is that I have to write code to handle the Manipulation events. Code that I didnt have to write when using the TouchablePanel from your framework.

1. What would be the best to do if one wanted to upgrade his app to use the .Net 4.0 framework?

2. Is it likely that there will be a new set of controls with the specific multitouch behaviour (just like TouchablePanel and the DraggableScrollViewer) created with .Net 4.0?

Thanks and kind regards, Momoski

Mar 18, 2010 at 10:06 PM

In MTV there is no controls that use WM_TOUCH.

1. Handle Manupulation code in own code. Or wait for Surface toolkit for Windows touch. http://blogs.msdn.com/devkeydet/archive/2009/11/21/surface-toolkit-for-windows-touch.aspx

2. WPF part of MTV will not be further developed.