MTVista - Win7 - MS Surface HOW?!?

Mar 15, 2010 at 10:26 AM

Hello,

we've a ms surface unit and we would like to use the touch-based input provided by the vision system also for normal desktop applications.

I've tried to install your driver on both on Windows Vista (the one shipped with the unit) and on Win7 (running on the surface in a separate partition) but in both cases when I launch the Multitouch.Service.Console.exe it just can found the MultiMouse device (correctly working) but not the Vision System input!

How can I fix it? Have I to install some vision system input driver for win7?

Thanks a lot for your Help

Simone

Coordinator
Mar 15, 2010 at 7:57 PM

Hello Simone,

you will have to compile the source code from the latest changeset. Make sure you select "Debug with Surface" configuration, otherwise Surface input provider will not be compiled. The driver can only be installed on Windows 7. After everything is compiled, start Multitouch.Service.Console.exe and then Multitouch.Configuration.WPF.exe to switch the input provider to Surface input provider (you have to make this only once). After that, you can start Multitouch.Driver.Console.exe. Make sure you start ...Service.Console BEFORE ....Driver.Console.
Hope this helps.

Daniel

Mar 16, 2010 at 8:26 AM

Thank you very much for the help!

Any hints about how to compile sources? It can be done with Visual Studio included with the MS Surface SDK? There's a script I can run to do all the build tasks (a kind of ant file as happens with java sources)?

Sorry but I'm not friendly with MS technologies.

Thanks again!

Simone

Mar 16, 2010 at 4:12 PM
Edited Mar 16, 2010 at 4:12 PM

Sorry for my previous post, I didn't see the how-to-compile instructions in the home page.

I managed to compile all the components, using the "Debug with surface" config for the ImputProviders and "Debug" for the other components.

But now I've another problem:

When I run the Multitouch.Service.Console from the Surface unit I get the following error: "Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.", thus the Configuration.WPF and Driver.Console file don't launch.

Unable to load one or more of the requested types. Retrieve the LoaderExceptions
 property for more information.

What kind of problem can be? And, I didn't installed a new version of the driver, since I didn't find the Driver dir in this distribution. I'm still running the driver I've installed from the official release in my first try (and that was working with the mouse input) . Can be this one the problem?

Thanks very much

Simone

 

Mar 17, 2010 at 1:29 PM

I thought that the problem could have been the fact that I compiled the source not on the surface unit but from a separate wkstation. So, I was trying to compile it directly on the surface unit but I couldn't be able to install the Surface SDK into Win 7 running on the surface.

If I try to install the Surface SDKWS (wkstation edition) the system say that I cannot install it on a surface unit, if install the "surface sdk unit edition" (shipped with the unit) it says that is not compatible with win7 (required vista SP1)

Any possible hint for a solution? Does anybody managed to run the SDK on a surface unit  running win7?

Thanks

Mar 9, 2011 at 2:55 PM

Yes, I managed to setup Win7 on a Surface 1.0 Unit and compile MultiTouchVista on it. Look at this thread for details.